Word to describe the Operating System size?
I want to have an enum that describes the "wid开发者_运维知识库th" of the Operating System.
The Values will be OS32 or OS64, but what is a good name for the enum its self?
enum OS_SIZE
{
OS32,
OS64
}
The best I can come up with is "OS Size", or maybe "OS Word Size" but I don't really like these. Is there a term in the industry that is used to describe the underlying word width of the operating system?
Bitness
PointerSize
WordLength
.
WMI calls it AddressWidth
, for example.
It's not the size of the OS, but the number of bits of a main memory address: 32 bits vs. 64 bits, which is also the size of a pointer.
Either case, the main difference is from a hardware architecture point of view, so I'd say "Number of Bits in Architecture Address", NoBiAA, or just "ARCH_ADDR_SIZE
".
OSWordSize
and OSWordBitSize
both work for me.
精彩评论