C/C++ naming conventions for variables: some_variable vs somevariable
I am wondering what is actually the preferred way o开发者_运维问答f naming variables: some_variable or somevariable. Looking at some libraries, I have seen both. What is more, some wide-spread style conventions like Google C++ Style Guide allow both.
What do you prefer and why? Is there a rule or good practice which tells when to use which? And does the same applies to argument names in functions/methods?
And is mixing those two conventions a good idea? If yes, when should the first naming conventions be used, and when the second one?
Use what's most readable and least confusing.
You should follow whatever naming convention makes sense to you.
For me, I always use camelCase for variables and PascalCase for public methods and properties.
The C++ standard libraries use both conventions for function and class names, though the _
convention is apparently gaining popularity (it's used in most recent additions, since the STL got standardized). Stick with your project guidelines, or make up your own, but apply them consistently.
My personal style is to use some_function
for functions, somevar
for variables, PascalCase
for class names. I don't have a copy of The C++ Programming Language by Stroustrup around, but I believe this is his style as well.
精彩评论